# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(coffee|pots?)(?:\n)"
test_str = ("import re\n\n"
"string = \"\"\"\n"
"All I want is a proper cup of coffee\n"
"Made in a proper copper coffee pot\n"
"I may be off my dot\n"
"But I want a cup of coffee\n"
"From a proper coffee pot\n"
"Tin coffee pots and iron coffee pots\n"
"They’re no use to me\n"
"If I can’t have a proper cup of coffee\n"
"In a proper copper coffee pot\n"
"I’ll have a cup of tea.\n"
"\"\"\"\n\n"
"pattern = r'coffee\\n|pot\\n|pots\\n'\n"
"print(re.findall(pattern, string))")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.