re = /(coffee|pots?)(?:\n)/m
str = 'import re
string = """
All I want is a proper cup of coffee
Made in a proper copper coffee pot
I may be off my dot
But I want a cup of coffee
From a proper coffee pot
Tin coffee pots and iron coffee pots
They’re no use to me
If I can’t have a proper cup of coffee
In a proper copper coffee pot
I’ll have a cup of tea.
"""
pattern = r\'coffee\\n|pot\\n|pots\\n\'
print(re.findall(pattern, string))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end