import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(coffee|pots?)(?:\\n)";
final String string = "import re\n\n"
+ "string = \"\"\"\n"
+ "All I want is a proper cup of coffee\n"
+ "Made in a proper copper coffee pot\n"
+ "I may be off my dot\n"
+ "But I want a cup of coffee\n"
+ "From a proper coffee pot\n"
+ "Tin coffee pots and iron coffee pots\n"
+ "They’re no use to me\n"
+ "If I can’t have a proper cup of coffee\n"
+ "In a proper copper coffee pot\n"
+ "I’ll have a cup of tea.\n"
+ "\"\"\"\n\n"
+ "pattern = r'coffee\\n|pot\\n|pots\\n'\n"
+ "print(re.findall(pattern, string))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}