#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+?(?=,)"
Local $sString = "ERROR 1: /home/rphillips/Desktop/empties/BN25_2106.tif, band 1: Failed to compute statistics, no valid pixels found in sampling."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")