import Foundation
let pattern = #".+?(?=,)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ERROR 1: /home/rphillips/Desktop/empties/BN25_2106.tif, band 1: Failed to compute statistics, no valid pixels found in sampling."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}