using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?(?=,)";
string input = @"ERROR 1: /home/rphillips/Desktop/empties/BN25_2106.tif, band 1: Failed to compute statistics, no valid pixels found in sampling.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}