re = /.+?(?=,)/
str = 'ERROR 1: /home/rphillips/Desktop/empties/BN25_2106.tif, band 1: Failed to compute statistics, no valid pixels found in sampling.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end