#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(?:.*\/)?[^\/.]+$"
Local $sString = "https://subdomain.example.com/test" & @CRLF & _
"https://subdomain.example.com/paht/test.css" & @CRLF & _
"https://subdomain.example.com/path/path/test.js" & @CRLF & _
"https://example.com/test/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")