$re = '/^https?:\/\/(?:.*\/)?[^\/.]+$/m';
$str = 'https://subdomain.example.com/test
https://subdomain.example.com/paht/test.css
https://subdomain.example.com/path/path/test.js
https://example.com/test/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);