package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(?:.*\/)?[^\/.]+$`)
var str = `https://subdomain.example.com/test
https://subdomain.example.com/paht/test.css
https://subdomain.example.com/path/path/test.js
https://example.com/test/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}