re = /^https?:\/\/(?:.*\/)?[^\/.]+$/m
str = 'https://subdomain.example.com/test
https://subdomain.example.com/paht/test.css
https://subdomain.example.com/path/path/test.js
https://example.com/test/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end