#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?x)(\S+) \h+ (*SKIP) (?= (?>\S+\h+)*? \1 (?!\S) )"
Local $sString = "Mike Tyson 1. Street 1234 Vietnam ML(12534/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632) " & @CRLF & _
"Mike Tyson 2. Street 1235 Vietnam2 ML(1254/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632) " & @CRLF & _
"Mike Tyson 2. Street 1235 Vietnam2 ML(1254/9762) Mike Tyson 1234 1. Street Vietnam ML(12534/97632) "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)