$re = '/(\S+) \h+ (*SKIP) (?= (?>\S+\h+)*? \1 (?!\S) )/x';
$str = 'Mike Tyson 1. Street 1234 Vietnam ML(12534/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)
Mike Tyson 2. Street 1235 Vietnam2 ML(1254/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)
Mike Tyson 2. Street 1235 Vietnam2 ML(1254/9762) Mike Tyson 1234 1. Street Vietnam ML(12534/97632) ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;