const regex = /(\S+) \h+ (*SKIP) (?= (?>\S+\h+)*? \1 (?!\S) )/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+) \\h+ (*SKIP) (?= (?>\\S+\\h+)*? \\1 (?!\\S) )', 'g')
const str = `Mike Tyson 1. Street 1234 Vietnam ML(12534/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)
Mike Tyson 2. Street 1235 Vietnam2 ML(1254/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)
Mike Tyson 2. Street 1235 Vietnam2 ML(1254/9762) Mike Tyson 1234 1. Street Vietnam ML(12534/97632) `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);