using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+) \h+ (*SKIP) (?= (?>\S+\h+)*? \1 (?!\S) )";
string substitution = @"";
string input = @"Mike Tyson 1. Street 1234 Vietnam ML(12534/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)
Mike Tyson 2. Street 1235 Vietnam2 ML(1254/97632) Mike Tyson 1234 1. Street Vietnam ML(12534/97632)
Mike Tyson 2. Street 1235 Vietnam2 ML(1254/9762) Mike Tyson 1234 1. Street Vietnam ML(12534/97632) ";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}