#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/((((([0-9])|(?:[1-2][0-9])|(?:3[0-2]))|(([1-9]?\\d|1\\d\\d|25[0-5]|2[0-4]\\d)\.){3}([1-9]?\\d|1\\d\\d|25[0-5]|2[0-4]\\d)(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])))|(((255\.){3}(255|254|252|248|240|224|192|128|0+))|((255\.){2}(255|254|252|248|240|224|192|128|0+)\.0)|((255\.)(255|254|252|248|240|224|192|128|0+)(\.0+){2})|((255|254|252|248|240|224|192|128|0+)(\.0+){3})))$"
Local $sString = "0.0.0.0/32" & @CRLF & _
"10.10.10.10/32" & @CRLF & _
"10.10.10.10/255.255.255.255" & @CRLF & _
"99.99.99.99" & @CRLF & _
"100.100.100.100" & @CRLF & _
"199.199.199.199" & @CRLF & _
"200.200.200.200" & @CRLF & _
"255.255.255.255" & @CRLF & _
"255.255.255.255/24" & @CRLF & _
"256.256.256.256" & @CRLF & _
"1.1.1.1.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")