$re = '/^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/((((([0-9])|(?:[1-2][0-9])|(?:3[0-2]))|(([1-9]?\\\\d|1\\\\d\\\\d|25[0-5]|2[0-4]\\\\d)\.){3}([1-9]?\\\\d|1\\\\d\\\\d|25[0-5]|2[0-4]\\\\d)(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])))|(((255\.){3}(255|254|252|248|240|224|192|128|0+))|((255\.){2}(255|254|252|248|240|224|192|128|0+)\.0)|((255\.)(255|254|252|248|240|224|192|128|0+)(\.0+){2})|((255|254|252|248|240|224|192|128|0+)(\.0+){3})))$/m';
$str = '0.0.0.0/32
10.10.10.10/32
10.10.10.10/255.255.255.255
99.99.99.99
100.100.100.100
199.199.199.199
200.200.200.200
255.255.255.255
255.255.255.255/24
256.256.256.256
1.1.1.1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);