import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\/((((([0-9])|(?:[1-2][0-9])|(?:3[0-2]))|(([1-9]?\\\\d|1\\\\d\\\\d|25[0-5]|2[0-4]\\\\d)\\.){3}([1-9]?\\\\d|1\\\\d\\\\d|25[0-5]|2[0-4]\\\\d)(([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\\.){3}([0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])))|(((255\\.){3}(255|254|252|248|240|224|192|128|0+))|((255\\.){2}(255|254|252|248|240|224|192|128|0+)\\.0)|((255\\.)(255|254|252|248|240|224|192|128|0+)(\\.0+){2})|((255|254|252|248|240|224|192|128|0+)(\\.0+){3})))$";
final String string = "0.0.0.0/32\n"
+ "10.10.10.10/32\n"
+ "10.10.10.10/255.255.255.255\n"
+ "99.99.99.99\n"
+ "100.100.100.100\n"
+ "199.199.199.199\n"
+ "200.200.200.200\n"
+ "255.255.255.255\n"
+ "255.255.255.255/24\n"
+ "256.256.256.256\n"
+ "1.1.1.1.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}