using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ab(?=(.*?)(bc)(.*))(?!.*(?:a|cb|cd).*\3)\1\2";
string input = @"0abbc1ab2bc3ababc4abcbbc5ab6bc7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}