re = /ab(?=(.*?)(bc)(.*))(?!.*(?:a|cb|cd).*\3)\1\2/m
str = '0abbc1ab2bc3ababc4abcbbc5ab6bc7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end