$re = '/ab(?=(.*?)(bc)(.*))(?!.*(?:a|cb|cd).*\3)\1\2/m';
$str = '0abbc1ab2bc3ababc4abcbbc5ab6bc7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);