using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div[^>]+>[^<]+<\/div><span>([^<]+)<\/span>";
string input = @"<div class=""hyphenate"">Томатный соус</div><span>20 рубл</span>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}