package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div[^>]+>[^<]+<\/div><span>([^<]+)<\/span>`)
var str = `<div class="hyphenate">Томатный соус</div><span>20 рубл</span>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}