$re = '/<div[^>]+>[^<]+<\/div><span>([^<]+)<\/span>/';
$str = '<div class="hyphenate">Томатный соус</div><span>20 рубл</span>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);