const regex = /<div[^>]+>[^<]+<\/div><span>([^<]+)<\/span>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div[^>]+>[^<]+<\\\/div><span>([^<]+)<\\\/span>', '')
const str = `<div class="hyphenate">Томатный соус</div><span>20 рубл</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}