#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{3}(?:-\d{3})?(?:\s*(?:,|and|or)\s*\d{3}(?:-\d{3})?)*(?=,|$)"
Local $sString = "345" & @CRLF & _
"346-348" & @CRLF & _
"234,235,236,237-239" & @CRLF & _
"234, 235, 236, 237-239" & @CRLF & _
"234,234, 236 and 237-239" & @CRLF & _
"234,234, 236 or 237-239" & @CRLF & _
"" & @CRLF & _
"3454" & @CRLF & _
"454,4567 (match only 454)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")