const regex = /^\d{3}(?:-\d{3})?(?:\s*(?:,|and|or)\s*\d{3}(?:-\d{3})?)*(?=,|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{3}(?:-\\d{3})?(?:\\s*(?:,|and|or)\\s*\\d{3}(?:-\\d{3})?)*(?=,|$)', 'gm')
const str = `345
346-348
234,235,236,237-239
234, 235, 236, 237-239
234,234, 236 and 237-239
234,234, 236 or 237-239
3454
454,4567 (match only 454)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}