#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$(\{(?:[^{}]+|(?1))+\})"
Local $sString = "${{"name": "Pack Rat", "mana_cost": "{1}{B}", "cmc": 2}}" & @CRLF & _
"" & @CRLF & _
"His name is "${name}", and he's a "${thing}"."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")