const regex = new RegExp('\\$(\\{(?:[^{}]+|(?1))+\\})', 'gm')
const str = `\${{"name": "Pack Rat", "mana_cost": "{1}{B}", "cmc": 2}}
His name is "\${name}", and he's a "\${thing}".`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}