import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$(\\{(?:[^\\{\\}]+|(?1))+\\})";
final String string = "${{\"name\": \"Pack Rat\", \"mana_cost\": \"{1}{B}\", \"cmc\": 2}}\n\n"
+ "His name is \"${name}\", and he's a \"${thing}\".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}