$re = '~\$(\{(?:[^{}]+|(?1))+\})~m';
$str = '${{"name": "Pack Rat", "mana_cost": "{1}{B}", "cmc": 2}}
His name is "${name}", and he\'s a "${thing}".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);