# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\S)-(?=\S)/ /gm;t' <<< "Adapter - BNC Male to BNC-Female, Right Angle
Adapter -BNC Male to BNC-Female, Right Angle
Adapter- BNC Male to BNC-Female, Right Angle
-test
test-
- test
test -
test-test"