use strict;
my $str = 'Adapter - BNC Male to BNC-Female, Right Angle
Adapter -BNC Male to BNC-Female, Right Angle
Adapter- BNC Male to BNC-Female, Right Angle
-test
test-
- test
test -
test-test';
my $regex = qr/(?<=\S)-(?=\S)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";