import Foundation
let pattern = #"(?<=\S)-(?=\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Adapter - BNC Male to BNC-Female, Right Angle
Adapter -BNC Male to BNC-Female, Right Angle
Adapter- BNC Male to BNC-Female, Right Angle
-test
test-
- test
test -
test-test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)