const regex = new RegExp('-(?P<percent>\\d+,\\d+)% vanaf (?P<amount>\\d+) (?P<unit>\\w+), vanaf (?P<start_date>\\d{2}/\\d{2}/\\d{4}) tot en met (?P<end_date>\\d{2}/\\d{2}/\\d{4})', 'g')
const str = `-20,00% vanaf 2 st, vanaf 26/07/2017 tot en met 08/08/2017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}