# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"-(?P<percent>\d+,\d+)% vanaf (?P<amount>\d+) (?P<unit>\w+), vanaf (?P<start_date>\d{2}/\d{2}/\d{4}) tot en met (?P<end_date>\d{2}/\d{2}/\d{4})"
test_str = "-20,00% vanaf 2 st, vanaf 26/07/2017 tot en met 08/08/2017"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.