re = /-(?P<percent>\d+,\d+)% vanaf (?P<amount>\d+) (?P<unit>\w+), vanaf (?P<start_date>\d{2}\/\d{2}\/\d{4}) tot en met (?P<end_date>\d{2}\/\d{2}\/\d{4})/
str = '-20,00% vanaf 2 st, vanaf 26/07/2017 tot en met 08/08/2017'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end