// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-(?P<percent>\d+,\d+)% vanaf (?P<amount>\d+) (?P<unit>\w+), vanaf (?P<start_date>\d{2}/\d{2}/\d{4}) tot en met (?P<end_date>\d{2}/\d{2}/\d{4})").unwrap();
let string = "-20,00% vanaf 2 st, vanaf 26/07/2017 tot en met 08/08/2017";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}