using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<{\s*_N\s*\(([^\)]*)\)\s*}>?";
string input = @"<{_N( 'some_domain_id' , 'this can be an arbitary string',{'a':'b','c':'d'})}>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}