// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<{\s*_N\s*\(([^\)]*)\)\s*}>?").unwrap();
let string = "<{_N( 'some_domain_id' , 'this can be an arbitary string',{'a':'b','c':'d'})}>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}