package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<{\s*_N\s*\(([^\)]*)\)\s*}>?`)
var str = `<{_N( 'some_domain_id' , 'this can be an arbitary string',{'a':'b','c':'d'})}>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}