re = /<{\s*_N\s*\(([^\)]*)\)\s*}>?/
str = '<{_N( \'some_domain_id\' , \'this can be an arbitary string\',{\'a\':\'b\',\'c\':\'d\'})}>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end