#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))"
Local $sString = "12" & @CRLF & _
"1" & @CRLF & _
"1234" & @CRLF & _
"00121300"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")