const regex = /((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))', 'g')
const str = `12
1
1234
00121300`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}