re = /((?<one>1)(?(<one>)2|$)|(?<two>2)(?(<two>)3|$)|(?<three>3)(?(<three>)4|$))/
str = '12
1
1234
00121300'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end