#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^CASE \d+:\r?\n-+[^\S\r\n]*(?:\r?\n(?!Drop Flow:).*)*\r?\n(Drop Flow: (TRUE|FALSE))[^\S\r\n]*(?:\r?\n(?!-).*)*\r?\n-"
Local $sString = "CASE 1:" & @CRLF & _
"---------------------------------- " & @CRLF & _
"Drop Pack: FALSE " & @CRLF & _
"Drop Flow: FALSE " & @CRLF & _
"---------------------------------- " & @CRLF & _
"CASE 2:" & @CRLF & _
"---------------------------------- " & @CRLF & _
"Drop Flow: TRUE " & @CRLF & _
"Fail Open: FALSE " & @CRLF & _
"Fail Close: FALSE " & @CRLF & _
"---------------------------------- " & @CRLF & _
"CASE 3:" & @CRLF & _
"---------------------------------- " & @CRLF & _
"Drop Flow: FALSE "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")