import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^CASE \\d+:\\r?\\n-+[^\\S\\r\\n]*(?:\\r?\\n(?!Drop Flow:).*)*\\r?\\n(Drop Flow: (TRUE|FALSE))[^\\S\\r\\n]*(?:\\r?\\n(?!-).*)*\\r?\\n-";
final String string = "CASE 1:\n"
+ "---------------------------------- \n"
+ "Drop Pack: FALSE \n"
+ "Drop Flow: FALSE \n"
+ "---------------------------------- \n"
+ "CASE 2:\n"
+ "---------------------------------- \n"
+ "Drop Flow: TRUE \n"
+ "Fail Open: FALSE \n"
+ "Fail Close: FALSE \n"
+ "---------------------------------- \n"
+ "CASE 3:\n"
+ "---------------------------------- \n"
+ "Drop Flow: FALSE ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}