# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^CASE \d+:\r?\n-+[^\S\r\n]*(?:\r?\n(?!Drop Flow:).*)*\r?\n(Drop Flow: (TRUE|FALSE))[^\S\r\n]*(?:\r?\n(?!-).*)*\r?\n-"
test_str = ("CASE 1:\n"
"---------------------------------- \n"
"Drop Pack: FALSE \n"
"Drop Flow: FALSE \n"
"---------------------------------- \n"
"CASE 2:\n"
"---------------------------------- \n"
"Drop Flow: TRUE \n"
"Fail Open: FALSE \n"
"Fail Close: FALSE \n"
"---------------------------------- \n"
"CASE 3:\n"
"---------------------------------- \n"
"Drop Flow: FALSE ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.