const regex = new RegExp('^CASE \\d+:\\r?\\n-+[^\\S\\r\\n]*(?:\\r?\\n(?!Drop Flow:).*)*\\r?\\n(Drop Flow: (TRUE|FALSE))[^\\S\\r\\n]*(?:\\r?\\n(?!-).*)*\\r?\\n-', 'gm')
const str = `CASE 1:
----------------------------------
Drop Pack: FALSE
Drop Flow: FALSE
----------------------------------
CASE 2:
----------------------------------
Drop Flow: TRUE
Fail Open: FALSE
Fail Close: FALSE
----------------------------------
CASE 3:
----------------------------------
Drop Flow: FALSE `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}