using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<number>\d+(\.\d+)?)(?P<quantifier>\W?[a-z,A-Z,А-Я,а-я])?";
string input = @"Необходимо принимать сумму
Варианты
20.0
20
5к
5 к
5 т
2 000
К и т должны быть отдельно";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}